<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>Ben&#8217;s Story of Firefox OS | Blog: timdream</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="stylesheet" type="text/css" media="all" href="https://blog.timc.idv.tw/wp-content/themes/toolbox-for-blog-timc/style.css" />
<link rel="pingback" href="https://blog.timc.idv.tw/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://blog.timc.idv.tw/wp-content/themes/toolbox/js/html5.js" type="text/javascript"></script>
<![endif]-->

<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="jAM7mnChRK-NynOoMumRx1ZUm54Pcj8Ao6zKFADrCVQ" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Blog: timdream &raquo; Feed" href="https://blog.timc.idv.tw/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blog: timdream &raquo; Comments Feed" href="https://blog.timc.idv.tw/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blog: timdream &raquo; Ben&#8217;s Story of Firefox OS Comments Feed" href="https://blog.timc.idv.tw/posts/bens-story-of-firefox-os/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.timc.idv.tw\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='social-logos-css'  href='https://blog.timc.idv.tw/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://blog.timc.idv.tw/wp-content/plugins/jetpack/css/jetpack.css?ver=4.7' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.timc.idv.tw/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://blog.timc.idv.tw/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://blog.timc.idv.tw/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.2'></script>
<link rel='https://api.w.org/' href='https://blog.timc.idv.tw/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.timc.idv.tw/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.timc.idv.tw/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='好好的花時間' href='https://blog.timc.idv.tw/posts/time-well-spent-zh/' />
<meta name="generator" content="WordPress 4.7.3" />
<link rel="canonical" href="https://blog.timc.idv.tw/posts/bens-story-of-firefox-os/" />
<link rel='shortlink' href='https://wp.me/p38Xvt-Ee' />
<link rel="alternate" type="application/json+oembed" href="https://blog.timc.idv.tw/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.timc.idv.tw%2Fposts%2Fbens-story-of-firefox-os%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.timc.idv.tw/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.timc.idv.tw%2Fposts%2Fbens-story-of-firefox-os%2F&#038;format=xml" />
<link rel="payment" type="text/html" title="Flattr this!" href="https://flattr.com/submit/auto?user_id=timdream&amp;url=https%3A%2F%2Fblog.timc.idv.tw%2Fposts%2Fbens-story-of-firefox-os%2F&amp;hidden=1&amp;language=en_GB&amp;category=text&amp;title=Ben%26%238217%3Bs+Story+of+Firefox+OS&amp;description=EmailFacebookTwitterGooglePocket&amp;tags=Planet+Mozilla%2CPlanet+MozTW%2Cblog" />

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//widgets.wp.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<style type='text/css'>img#wpstats{display:none}</style><link rel="amphtml" href="https://blog.timc.idv.tw/posts/bens-story-of-firefox-os/amp/" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Ben&#8217;s Story of Firefox OS" />
<meta property="og:url" content="https://blog.timc.idv.tw/posts/bens-story-of-firefox-os/" />
<meta property="og:description" content="&lt;img src=&#8221; alt=&#8221;&#8221; width=&#8221;640&#8243; height=&#8221;332&#8243; class=&#8221;aligncenter size-large wp-image-2498&#8243; /&gt; Like my good old colleague Ben Francis, I too …" />
<meta property="article:published_time" content="2017-03-13T14:50:51+00:00" />
<meta property="article:modified_time" content="2017-03-13T15:47:02+00:00" />
<meta property="article:author" content="https://www.facebook.com/timdream" />
<meta property="og:site_name" content="Blog: timdream" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@timdream" />
<meta name="twitter:image" content="https://blog.timc.idv.tw/wp-content/uploads/2017/02/tiramisu-icon-64-shadow.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@timdream" />
<link rel="icon" href="https://blog.timc.idv.tw/wp-content/uploads/2017/02/tiramisu-icon-64-shadow.png" sizes="32x32" />
<link rel="icon" href="https://blog.timc.idv.tw/wp-content/uploads/2017/02/tiramisu-icon-64-shadow.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://blog.timc.idv.tw/wp-content/uploads/2017/02/tiramisu-icon-64-shadow.png" />
<meta name="msapplication-TileImage" content="https://blog.timc.idv.tw/wp-content/uploads/2017/02/tiramisu-icon-64-shadow.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.2: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-401106-3']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
</head>

<body class="post-template-default single single-post postid-2494 single-format-standard single-author">
<div id="page" class="hfeed">
	<header id="branding" role="banner">
		<hgroup>
			<h1 id="site-title"><a href="https://blog.timc.idv.tw/" title="Blog: timdream" rel="home">Blog: timdream</a></h1>
			<h2 id="site-description">網路、Mozilla、天文、物理、科學、科幻、社會 …… 自由</h2>
		</hgroup>

		<nav id="access" role="navigation">
			<h1 class="assistive-text section-heading">Main menu</h1>
			<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">Skip to content</a></div>

			<div class="menu-top-container"><ul id="menu-top" class="menu"><li id="menu-item-1141" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1141"><a href="https://timc.idv.tw/">Home</a></li>
<li id="menu-item-1354" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1354"><a href="https://blog.timc.idv.tw/">Blog</a></li>
<li id="menu-item-1355" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1355"><a href="https://timdream.org/">Portfolio</a></li>
<li id="menu-item-1370" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1370"><a href="https://twitter.com/#!/timdream">Twitter</a></li>
<li id="menu-item-1371" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1371"><a href="https://www.facebook.com/timdream">Facebook</a></li>
</ul></div>		</nav><!-- #access -->
	</header><!-- #branding -->

	<div id="main">
		<div id="primary">
			<div id="content" role="main">

			
					<nav id="nav-above">
		<h1 class="assistive-text section-heading">Post navigation</h1>

	
		<div class="nav-previous"><a href="https://blog.timc.idv.tw/posts/time-well-spent-zh/" rel="prev"><span class="meta-nav">&larr;</span> 好好的花時間</a></div>		
	
	</nav><!-- #nav-above -->
	
				
<article id="post-2494" class="post-2494 post type-post status-publish format-standard hentry category-internet category-programming category-thoughts tag-planet-mozilla tag-planet-moztw">
	<header class="entry-header">
		<h1 class="entry-title">Ben&#8217;s Story of Firefox OS</h1>

		<div class="entry-meta">
			<span class="sep">Posted on </span><a href="https://blog.timc.idv.tw/posts/bens-story-of-firefox-os/" title="10:50 pm" rel="bookmark"><time class="entry-date" datetime="2017-03-13T22:50:51+00:00" pubdate>March 13, 2017</time></a><span class="byline"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="https://blog.timc.idv.tw/posts/author/timdream/" title="View all posts by timdream" rel="author">timdream</a></span></span>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	<div class="entry-content">
		<p><iframe src="https://api.medium.com/embed?type=story&amp;path=%2F%40bfrancis%2Fthe-story-of-firefox-os-cb5bf796e8fb&amp;id=0&amp;collapsed=" allowtransparency="true" title="Embedded story" class="aligncenter" width="640" height="320" frameborder="0">&lt;img src=&#8221;https://blog.timc.idv.tw/wp-content/uploads/2017/03/the-story-of-firefox-os-1024&#215;531.jpg&#8221; alt=&#8221;&#8221; width=&#8221;640&#8243; height=&#8221;332&#8243; class=&#8221;aligncenter size-large wp-image-2498&#8243; /&gt;</iframe></p>
<p>Like my good old colleague Ben Francis, I too have a lot to say about Firefox OS.</p>
<p>It&#8217;s been little over a year since my team and I moved away from Firefox OS and the ill-fated Connected Devices group. Over the course of last year, each time I think about the Firefox OS experience, I arrived at different conclusions and complicated, sometimes emotional, belives. I didn&#8217;t feel I am ready to take a snapshot of these thoughts and publish it permanently, so I didn&#8217;t write about it here. Frankly, I don&#8217;t even think I am ready now.</p>
<p><a href="https://medium.com/@bfrancis/the-story-of-firefox-os-cb5bf796e8fb">In his post</a>, Ben has pointed out many of the turning points of the project. I agree with many of his portrayals, most importantly, lost of direction between being a product (which must ship fast and deliver whatever partners/consumers wanted and used to) and a research project (which involves engineering endeavors that answer questions asked in the original announcement). I, however, have not figured out what can be done instead (which Ben proposed in his post nicely).</p>
<p>Lastly, a final point: to you, this might as well be another story in the volatile tech industry, but to me, I felt the cost of people enormously whenever a change was announced during the “slow death” of Firefox OS.</p>
<p>People moves on and recovers, including me (which fortunately wasn&#8217;t nearly being hit the hardest). I can only extend my best wishes to those who had fought the good fight with.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="https://blog.timc.idv.tw/posts/bens-story-of-firefox-os/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-2494" class="share-facebook sd-button share-icon" href="https://blog.timc.idv.tw/posts/bens-story-of-firefox-os/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-2494" class="share-twitter sd-button share-icon" href="https://blog.timc.idv.tw/posts/bens-story-of-firefox-os/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-2494" class="share-google-plus-1 sd-button share-icon" href="https://blog.timc.idv.tw/posts/bens-story-of-firefox-os/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon" href="https://blog.timc.idv.tw/posts/bens-story-of-firefox-os/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li></ul></div></div></div>			</div><!-- .entry-content -->

	<footer class="entry-meta">
		This entry was posted in <a href="https://blog.timc.idv.tw/categories/media/internet/" rel="category tag">Internet</a>, <a href="https://blog.timc.idv.tw/categories/programming/" rel="category tag">Programming</a>, <a href="https://blog.timc.idv.tw/categories/me-me-me/thoughts/" rel="category tag">Thoughts</a> and tagged <a href="https://blog.timc.idv.tw/posts/tag/planet-mozilla/" rel="tag">Planet Mozilla</a>, <a href="https://blog.timc.idv.tw/posts/tag/planet-moztw/" rel="tag">Planet MozTW</a>. Bookmark the <a href="https://blog.timc.idv.tw/posts/bens-story-of-firefox-os/" title="Permalink to Ben&#8217;s Story of Firefox OS" rel="bookmark">permalink</a>.
		Share the <a href="https://wp.me/p38Xvt-Ee" title="Shortlink to Ben&#8217;s Story of Firefox OS" rel="shortlink">short link</a>.
			</footer><!-- .entry-meta -->
</article><!-- #post-2494 -->

					<nav id="nav-below">
		<h1 class="assistive-text section-heading">Post navigation</h1>

	
		<div class="nav-previous"><a href="https://blog.timc.idv.tw/posts/time-well-spent-zh/" rel="prev"><span class="meta-nav">&larr;</span> 好好的花時間</a></div>		
	
	</nav><!-- #nav-below -->
	
					<div id="comments">
	
	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/posts/bens-story-of-firefox-os/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://blog.timc.idv.tw/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='2494' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e700113610" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="102"/></p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments -->

			
			</div><!-- #content -->
		</div><!-- #primary -->

		<div id="secondary" class="widget-area" role="complementary">
						<aside id="text-120056608" class="widget widget_text">			<div class="textwidget"><p><img src="https://gravatar.com/avatar/2becaf1073957bdad2f06e183731131d?s=150" alt="" style="display: block; margin: 0 auto; width: 150px; height: 150px" class="author-image" /></p>

<p><strong>Timothy Guan-tin Chien</strong> <br />Creates software, mostly on Web, in JavaScript. Have immense curiosity on how the world works. Looking for ways to advance Open Web. Opinions are my own.</p>
</div>
		</aside><aside id="search-2" class="widget widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://blog.timc.idv.tw/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></aside><aside id="text-120056606" class="widget widget_text">			<div class="textwidget"><p><a href="https://creativecommons.org/licenses/by-nc-sa/2.5/tw/"><img style="display: block; margin: 0 auto; border-radius: 2px" alt="Creative Commons License" style="border-width:0" src="https://i.creativecommons.org/l/by-nc-sa/2.5/tw/80x15.png"/></a></p>
<!--
	<rdf:RDF xmlns="http://web.resource.org/cc/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
		<Work rdf:about="">
			<license rdf:resource="https://creativecommons.org/licenses/by-nc-sa/2.5/tw/" />
		</Work>
		<License rdf:about="https://creativecommons.org/licenses/by-nc-sa/2.5/tw/">
			<permits rdf:resource="http://web.resource.org/cc/Reproduction"/>
			<permits rdf:resource="http://web.resource.org/cc/Distribution"/>
			<requires rdf:resource="http://web.resource.org/cc/Notice"/>
			<requires rdf:resource="http://web.resource.org/cc/Attribution"/>
			<prohibits rdf:resource="http://web.resource.org/cc/CommercialUse"/>
			<permits rdf:resource="http://web.resource.org/cc/DerivativeWorks"/>
			<requires rdf:resource="http://web.resource.org/cc/ShareAlike"/>
		</License>
	</rdf:RDF>
-->
</div>
		</aside><aside id="top-posts-2" class="widget widget_top-posts"><h1 class="widget-title">Top Posts</h1><ul>				<li>
										<a href="https://blog.timc.idv.tw/posts/bens-story-of-firefox-os/" class="bump-view" data-bump-view="tp">
						Ben&#039;s Story of Firefox OS					</a>
									</li>
							<li>
										<a href="https://blog.timc.idv.tw/posts/stellarium-0-81-landscape/" class="bump-view" data-bump-view="tp">
						Stellarium 0.8.1+自製地景					</a>
									</li>
							<li>
										<a href="https://blog.timc.idv.tw/posts/internet-privacy-and-security-cookie-https/" class="bump-view" data-bump-view="tp">
						網路資料個人隱私與安全：Cookie 與 HTTPS 加密					</a>
									</li>
							<li>
										<a href="https://blog.timc.idv.tw/posts/invoice-helper/" class="bump-view" data-bump-view="tp">
						手開發票檢查					</a>
									</li>
							<li>
										<a href="https://blog.timc.idv.tw/posts/han-vertical-writing-in-css3-and-javascript/" class="bump-view" data-bump-view="tp">
						CSS3 與 Javascript 東亞文字直排					</a>
									</li>
			</ul></aside>		</div><!-- #secondary .widget-area -->

		
	</div><!-- #main -->

	<footer id="colophon" role="contentinfo">
		<div id="site-generator">
						<a href="http://wordpress.org/" title="Semantic Personal Publishing Platform" rel="generator">Proudly powered by WordPress</a>
			<span class="sep"> | </span>
			Theme: Toolbox by <a href="http://automattic.com/" rel="designer">Automattic</a>.		</div>
	</footer><!-- #colophon -->
</div><!-- #page -->

<!-- Always show branding when the browser does not support srcipting -->
<noscript>
  <style>
  #branding {
    margin-top: 0 !important;
  }
  </style>
</noscript>

<!-- Reveal the branding but correct the scroll offset along the way -->
<script>
jQuery(function($) {
  // offsetTop will be available after another tick (except for Firefox)
  setTimeout(function() {
    var $el = $('#branding');
    var offsetTop = $el[0].offsetTop;
    $el.addClass('reveal');

    // Attempt to set scrollTop if we have cause the scrollHeight to grow.
    if (offsetTop < 0) {
      // Set scrollTop to both <body> and <html>.
      // Firefox scrolls HTML natually and Safari scrolls BODY.
      // (the wrong one will be ignored)
      document.body.scrollTop =
        document.documentElement.scrollTop -= offsetTop;
    }
  });
});
</script>

<script type='text/javascript' src='https://blog.timc.idv.tw/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201711'></script>
<script type='text/javascript' src='https://blog.timc.idv.tw/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.timc.idv.tw/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.7'></script>
	<div id="sharing_email" style="display: none;">
		<form action="/posts/bens-story-of-firefox-os/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="https://blog.timc.idv.tw/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://stats.wp.com/e-201711.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.7',blog:'46464379',post:'2494',tz:'8',srv:'blog.timc.idv.tw'} ]);
	_stq.push([ 'clickTrackerInit', '46464379', '2494' ]);
</script>

</body>
</html>
